Jump to content
66-96 Ford Broncos - Early & Full Size
tspinks

84 bronco 2 feels like the brake is on

Recommended Posts

Hey guys, I have an '84 Bronco II 4 spd and I started having issues with it a few days ago.  When traveling from a stop the car feels like it has gone into gear but then it doesn't move, it feels just like it would if I had left the parking brake on (I did not).  After going from reverse to first a few times it started going (very slowly at first) then once I am moving the issue goes away.  Any ideas?

Share this post


Link to post
Share on other sites

Do you hear a clunk when it starts moving OK?  It could be that your brakes are sticking and in serious need of service, especially the rear set.

 

Good luck,

 

:)>-

Share this post


Link to post
Share on other sites

No clunk, it engages the gear then barely moves, and if I let the clutch out all the way the car will stall.

Share this post


Link to post
Share on other sites

Unless you have rebuilt the rear drums lately, I would still check on the rear brakes, the hardware is probably corroded and not letting the shoes release properly. 

 

Do you use the emergency brake when parking? If so, the cable may be corroded inside and slow to release.

 

:)>-

Share this post


Link to post
Share on other sites

Does it do this when the rig is cold as well?  Or is it just when everything is warmed up.?

Point being, I've seen similar symptoms with a bad rear diffentrial. As it warms up it binds & eventually locks.

Put rear up on Jack stands & try to rotate the wheels.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×