Jump to content
66-96 Ford Broncos - Early & Full Size
BroncoJoe19

Throttle Position sensor (TPS) replacement

Recommended Posts

I may have enough time and the weather may be cooperative enough for me to finally get around to replacing my TPS. IS there a trick to replacing it whitout taking stuff apart?

 

I tried to get at the two retaining screws, and it looks like it would be easiest to remove the entire throttle body assembly first, flip it backwards, and then replace the TPS.

Edited by BroncoJoe19

Share this post


Link to post
Share on other sites
I may have enough time and the weather may be cooperative enough for me to finally get around to replacing my TPS. IS there a trick to replacing it whitout taking stuff apart?

 

I tried to get at the two retaining screws, and it looks like it would be easiest to remove the entire throttle body assembly first, flip it backwards, and then replace the TPS.

Assuming that I do have to pull the throttle body assembly, is there a gasket? Should I get a new one, or should I use high temp silicon, or both or what?

Thanks

joe

Share this post


Link to post
Share on other sites

& there are 2 type of Bronco TPS's

 

Originally Posted by SeattleFSB

"A quote from my Chilton's manual:

 

"The TP Sensor has two versions, an adjustable and a non-adjustable; the difference being elongated mounting holes that allow the rotory sensor to be turned slightly to adjust the output voltage. The rotary TP sensor with round mounting holes are not adjustable".

 

 

JKossarides, it goes on to say:

 

"On 5.0L and 5.8L engines, position the TP sensor so that the pigtail points toward the IAC valve".

 

"Slide the rotary tangs into position over the shaft blade, then rotate the TP sensor CLOCKWISE only to the installed position. Failure to follow this step may result in high idle speeds for 5.0L and 5.8L engines"..."

 

 

 

"... learned that with the TPS with the round hole all you have to do is scribe it and then place the new TPS, turning your hand a bit left then place it over the TB shaft blade and turn it CW to the scribe mark then screw it down tight. The ring inside has little prongs or tanges which move so by doing it this way you insure they will engage with the end of the shaft. I guess I misunderstood thinking there was some sort of adjustment to set the voltage using the mulitmeter at that stage. The only other adjustment is to warm up the engine, shut it off and disconnect the TPS then start the engine and adjust the throttle stop screw with the tach at a desireable idle then reconnect..."

Share this post


Link to post
Share on other sites

Miesk5,

Thanks so much... it seems like you are always looking out for me.

 

Those posts were excellent!

I was hoping that there would be a magic little half upside down swivle ratchet reversed screwdriver that was magnetized that would make taking those screws out and putting them back in a snap.

 

Oh well, if my throttle body is as dirty as the one in the pictures, it will have been a well worthwhile effort to clean it up.

Of course the gasket is not available today, so I'll play with the grandkids. Tomorrow is another day.

 

THanks again... so much.

joe

Share this post


Link to post
Share on other sites

yw..anytime

 

I believe the screws also have Loctite on em from the factory.

Share this post


Link to post
Share on other sites
yw..anytime

 

I believe the screws also have Loctite on em from the factory.

Man.. you ain't friggin kiddin :blink:

I used a hand held impact srewdriver to break them free, and had to replace them when I was done. Cause i'd be able to get them on, but they would never come off again.

 

I replaced the TPS, and although the throttle body looked clean from the outside, it really needed a cleaning on the inside. I'm not quit sure but I think that one of the vacuum lines within the throttle body was clogged. THe truck is running better than ever!

 

THanks for all your help!

joe

Share this post


Link to post
Share on other sites

Wow!!! I just drove her to work today, 20 miles or so, half highway, half city.

 

I can't believe how much better she is running. Aparrantly she never ran correctly for as long as I had her. Her shift points were off, in that she would up shift into OD too soon, and would bog down prior to downshifting... way too often running in the low end of her torque curve. I thought that it was because of the slightly oversized tires... 33's. I have an E4OD trans with the OD switch on the dash and started manually going in and out of OD.

 

Now she does it all on her own... just like she is supposed to.

I think I'll keep her.

joe

Share this post


Link to post
Share on other sites

Just to round this out a little bit so that it is instructional.

The Haynes manual states that Adjsutment of the TPS is not necessary on the 4.9L All other models must be adjusted. If you are working on a 1990 or earlier model connect the negative probe of a digital voltmeter to the terminal of the TP sensor with the black/white wire, and the positive probe to the dark green/light green wire. Note: You may have to insert stick pins into the back of the connector where the wires go in, and connect the probes to the pins. If you are working on a 1991 or later negative to grey/red and psotive to grey/white.

WIth the ignition key turned ON rotate the TPS until the output voltage is 1.0 volt. Tighten and recheck your voltage.

 

NB: Earlier in the chapter when trouble shooting is states that the output voltage should be between 0.5 and 1.0 volts.

 

Even though my TPS had round holes, there was enough play that an adjustment was possible.

As a side not on my '90 the TPS I pulled off, and the new one I put on had different color wires.

Black was Sig Rtn

Orange was TP Sig

Green was V reference

With the throttle closed should get 1.0 volts between the orange and black and

with the throttle fully open 5 volts.

 

You should also get 5 volts From the computer to the TPS by checking Vref (Green) and ground SIg Rtn Black.

Share this post


Link to post
Share on other sites
I may have enough time and the weather may be cooperative enough for me to finally get around to replacing my TPS. IS there a trick to replacing it whitout taking stuff apart?

 

I tried to get at the two retaining screws, and it looks like it would be easiest to remove the entire throttle body assembly first, flip it backwards, and then replace the TPS.

 

This was just asked by my friend last Sunday. You can do it with just few easy steps. Anyways, here's the throttle position sensor replacement guide for you.

Edited by drewtiss

Share this post


Link to post
Share on other sites
I was hoping that there would be a magic little half upside down swivle ratchet reversed screwdriver that was magnetized that would make taking those screws out and putting them back in a snap.

 

joe

LMAO! I am going to have to ask my snap-on dealer about one of those.....

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...