Jump to content
66-96 Ford Broncos - Early & Full Size

Search the Community

Showing results for tags 'electrical fire on 92 Bronco'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Blogs

There are no results to display.

There are no results to display.

Forums

  • Welcome To BroncoZone.com!
    • BroncoZone.com News
    • Introductions
    • Trail Talk Lounge
    • How-To Tech Articles & Reviews
    • Bronco Zone Feature Truck
    • Events, Trail Runs, MnGs
  • General Ford Bronco Discussion
    • 66-77 Early Bronco
    • 78-79 Ford Bronco
    • 80-96 Ford Bronco
    • 2020 Ford Bronco
    • 97-Current Expedition & Excursion
    • 80-Current Bronco II & Explorer
    • Discusion general en español
  • Technical Support
    • 66-77 Early Bronco Tech Support
    • 78-79 Ford Bronco Tech Support
    • 80-96 Ford Bronco Tech Support
    • 97-Current Expedition & Excursion Tech Support
    • 80-Current Bronco II & Explorer Tech Support
    • Soporte tecnico en español
  • Classifieds
    • Click Here for BroncoGraveyard.com
    • Parts For Sale & Wanted
    • Trucks For Sale or Wanted
    • Vendor Showroom
    • Group Buys & Give Aways
  • Off Topic Discussion
    • Non-Bronco Pictures
    • VIP Lounge
    • Local Tavern
    • Jokes & Funny Stuff
    • Radio Control & Model Discussion
    • Testing...1...2...3...

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Favorite Bronco Year?

Found 1 result

  1. Well, 1 1/2 weeks ago my speedometer started freaking out and then went dead all together but I made it home. I went out to start it the next day and it wouldn't start. It would just click at the starter. It had burnt the wires all the way down to the starter and back up the ignition wire and the ground wire to the alternator. The starter is good because I can get it to engage off the car using jumper cables, so I know the starter is not burnt up and my check engine light comes on when I turn the key so I'm guessing the computer is okay. So what could I be missing because the engine still won't turn over and I even had the batteries recharged. I don't see and other burnt wires. Help!!
×
×
  • Create New...