Jump to content
66-96 Ford Broncos - Early & Full Size

Skitter302

Moderators
  • Content count

    408
  • Joined

  • Last visited

Status Replies posted by Skitter302

  1. Yo, Have you done much work on Ford Rangers? I've got a question about the electrical system.

    1. Skitter302

      Skitter302

      Did some more looking the circuit isn't ground switching. I'll have to find a diagram and find where the missing part of the puzzle is. If that doesn't work then I'll wiring the features back in using new wires with fuses in them.

    2. (See 5 other replies to this status update)

  2. Yo, Have you done much work on Ford Rangers? I've got a question about the electrical system.

    1. Skitter302

      Skitter302

      I'm a HVAC service tech by trade. Tracking down bad wiring or finding bad parts is what I do. I busted out the user manual and try'd to locate the bad fuse or fuses by description. When that didn't work I pulled all the fuses looking for a bad one. Not finding any bad fuses I pulled the radio and the HVAC controls and probed the back of them to find that no 12v was going to the knob that controls fan speed. I then moved on to the flasher relay to find 12v going to the pin that controls the hazards but no 12v going to the other half of the relay. If your correct and their is no fuse-able links then the wiring harness has a open in it. That is the only conclusion I can come up with since all the fuses were good.

      I even pulled and bypassed the blower relay and the blower works great. So what ever 12v signal goes through the relay to close it, isn't making it when the key is on. What ever the issue is its up stream of the fuses. What do you think?

    2. (See 5 other replies to this status update)

  3. Yo, Have you done much work on Ford Rangers? I've got a question about the electrical system.

    1. Skitter302

      Skitter302

      2005 Ranger 2.3L 2WD Single Cab, No Power Windows, No Power Door Locks, No Cruise control. AM/FM only radio.

      Having an issue where the Turn Signals don't work, but I do have emergency flashers. The Blower for the HVAC stuff isn't working, and the Hi beam lights don't work but Low beam do. All of these stopped working same morning the truck was driven to work.

      I have checked all fuses in the power dis. Box under the hood,  and all fuses in the pass side kick panel. All fuses are good, didn't have to replace any. So my guess at this point is a fuse-able link but I can't find a wiring diagram that shows me any.

      What are your thoughts?

    2. (See 5 other replies to this status update)

  4. I think I'm getting 12-13mpg... And my gas gauge works just fine. :NotBadFace:

    1. Skitter302

      Skitter302

      normal is 8-9mpg. This is different...

×