Jump to content


Photo

1995 Transmission Problem?


2 replies to this topic

#1 Pioneer

Pioneer

    Bronco Newbie

  • Members
  • 2 posts

Posted 21 May 2009 - 07:18 PM

Tonight was the first time this has happend on this truck but when i was going between 30-55mph my 0FF switch for my overdrive started blinking. As I continued to drive all I could hear was the engine reving up and not seeming to find a gear then it would snap in and continue driving. When I got it back on the interstate the light went off and shifted fine. I was only on the interstate for about 10miles and when I pulled off onto another 55mph speed zone it started flashing again. It didn't seem to shift and when it did it shifted hard. I find it weird that I just got it out of the shop for a water pump and then all of a sudden it seems I have transmission problems? Any help out there?

#2 Steve83

Steve83

    Bronco Guru

  • Members
  • PipPipPipPipPipPipPip
  • 924 posts
  • Gender:Male
  • Location:Memphis, TN 38002, USA, Earth, Milky Way
  • Interests:DVDs, MP3s, Broncos, Crown Vics, radio controlled models, home theater, home improvement

Posted 21 May 2009 - 09:04 PM

Take it back to the shop & complain. Let them tell you what it is & isn't. But check the fluid level (read the instructions stamped into the dipstick) before driving it.

The TCIL flashes when a transmission-related DTC is stored, but you can read them just like engine codes. Read the 7th post in this thread:
http://www.fordf150....pic.php?t=71346

#3 broncotough

broncotough

    Bronco Mechanic

  • Members
  • PipPipPipPip
  • 52 posts
  • Gender:Male
  • Location:bradenton, fl

Posted 23 May 2009 - 05:41 AM

Ive had this happen three times. The first time tranny was triying to lock up and slipped would not go faster then 5 mph, solution rebuilt tranny. the second time i was playing with some fuses and forgot one causing the tranny to run in a "default" mode. very hard shifting but no slipping. the last time it blinked the OD light it was a vehicle speed sensor on the rear axle. i hope its an easy fix for you. if you have it rebuilt i suggest you have someone you really trust. when i had mine rebuilt they used a lot of cheap parts. which left my truck stuck at a green light with a cooked 3 pinion aluminum Fwd planetary gear. the Lucas tranny fluid additive stops slips, but only for a short time. i used it on a Maxima and got another 5,000 out of it before it cooked the tranny.
White 96 Bronco xl blue interior
302 Msd coil, wires, cap, rotor, autolight plugs
Hedman long tube header tru dual flow master 40s 2 1/4 pipes
Rebuilt E4OD with steel 6 pinion fwd gear B&M shift kit
Borg Warner 13-56 manual shift w/ skid plate
custom rear drive shaft
Welded front D44 IFS
Ford 1/4 turn manual hubs
Rough country 6" suspension lift
36x13.50x15 super swamper IROKs on black steel wheels
Drilled and Slotted rotors
HD radio, 1000 watt amp, and PA system
4 point roll bar.
Regular hard top for winter
Custom cut hard top for summer
Ford lightning rear tube bumper
Tube front bumper.



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users